Ошибка запуска студии после обновления

Сергей Беляков добавил(а) 1 нед. назад
Без ответа

Обновил cuba до v6.6.1

При старте появляется ошибка "Could not install Gradle distribution from

https://services.gradle.org/distributions/gradle-3.4-bin.zip";

Если указать прямой путь к gradle-3.4 в Advanced, то cuba запускается, правда потом не выполняются команды типа gradlew projects или gradlew tasks в папке с проектом.

Комментарии (6)

фото
1

Похожие темы на форуме читал, предложенные там инструкции не помогли.

фото
1

Здравствуйте,

С какой версии Вы обновились?

Какая у Вас операционная система?

Данный URL (https://downloads.gradle.org/distributions/gradle-3.4-bin.zip) доступен с Вашей машины?

фото
1

Добрый день.

Обновлялся с 6.4.2 или 6.4.3.

ОС Windows 7 x64 Максимальная

gradle-3.4-bin.zip доступен, как раз его я и скачал и прописал в Advanced, иначе не стартует.

фото
1

1) При первом запуске Студия скачивает необходимый дистрибутив Gradle с указанного выше URL в папку ~/.gradle/wrapper/distr .

Попробуйте поместить туда "gradle-3.4-bin". CUBA Studio должна заработать без альтернативного Gradle.

2) Чтобы исправить "gradlew" попробуйте следующее:

Откройте проект в студии и выполните Build->Create or update Gradle wrapper. Если ~/.gradle/wrapper/distr/gradle-3.4-bin существует, то gradlew - сценарий должен заработать (или скачать и сохранить дистрибутив при первом обращении).

3) В любом случае, Вы можете установить Gradle (лучше версии 3.4-3.5) и использовать в командной строке gradle вместо gradlew.

фото
1

Предложенные варианты не помогли.

Скачал gradle-3.5-bin и прописал к нему путь в Advanced (C:\Gradle\gradle-3.5)

Буду ждать обновления платформы, может там что-то изменится.

фото
1

Установите переменную среды GRADLE_HOME и добавьте "%GRADLE_HOME%/bin" в Path. Вы сможете пользоваться gradle(точно также как gradlew) в командной строке и консоли IDE.

фото